Apple Quicktime 7.7.5 Multiple Vulnerabilities
PVS ID: 8140 FAMILY: Web Clients RISK: MEDIUM NESSUS ID:Not Available
Description: Synopsis :\n\nThe version of QuickTime on the remote machine is affected by multiple code execution vulnerabilities.\n\nVersions older than Quicktime 7.7.5 contain the following vulnerabilities:\n\n - Multiple buffer overflow vulnerabilities, which can be leveraged by an attacker to execute arbitrary code or application termination (2014-1246, CVE-2014-1248, CVE-2014-1249)\n\n - An out-of-bounds byte swapping issue in the handling of 'ttfo' elements, which can be leveraged by an attacker to execute arbitrary code or application termination (CVE-2014-1250)\n\n - A signedness issue in the handling of 'stsz' atoms, which can be leveraged by an attacker to execute arbitrary code or application termination (CVE-2014-1245)\n\n - A memory corruption issue when handling the 'dref' atoms, which can be leveraged by an attacker to execute arbitrary code or application termination (CVE-2014-1247)\n\nFor your information, the observed version of Quicktime: \n%L

Solution: Users of OS X Mavericks (v10.9) should upgrade to 10.9.2, which includes the Quicktime 7.7.5 update. All others should upgrade to version 7.7.5 or later.

CVE-2014-1250


Copyright Tenable Network Security Inc. 2014